blaze - the overview

This documentation has to cover a lot of topics. We tried to organize all information in a way that makes it easy for you to find what you are searching for. Let us know if we failed.

If you are already using blaze: Start reading. If you aren't using blaze (shame on you), you might want to know about the system requirements.

System requirements

blaze was tested and made to run on mostpart of standard hosting solutions. It was tested with PHP 5.5.9 to 7.1 and should run on nearly all PHP configurations you may encounter on shared hosting environments.

We recommend running blaze on Apache, which powers most shared hosting servers. We also can confirm that blaze might work on nginx as long as there is support for .htaccess and mod_rewrite.

These are the recommended system requirements:

  • Apache v2.2 or higher
  • PHP 5.6 or higher
  • mod_rewrite
  • Curl extension
  • Zip extension

These are the minimum system requirements we do support:

  • Apache v2.2 or higher
  • PHP 5.5.9 or higher
  • mod_rewrite

Some of the features will require other Apache modules to be installed (like mod_expires for proper expire headers on images) or certain PHP extensions (like zip for branding import/export). In modern times, these should be installed and activated on most servers.

In case you encounter a problem related to an incompatibility with your server setup, let us know and we'll see what we can do.

Check your server before buying blaze!

As we don't want you to buy blaze and not be able to use it, we provide a system checking script. You will find this script here: blaze.moay.de/#goblaze.